Overview: 7 maneiras de Contar Itens no Excel

Olá Amigos,

Segue um artigo que lhe ajudará a compreender 7 maneiras de contar itens no Excel , você pode ver os passos para a utilização de cada método nos itens abaixo.

Neste artigo você aprenderá a realizar a Contagem de números , contagem de todos os dados , ou a contagem de células em branco.

Utilizaremos a função COUNT ou CONT.NÚM em Português, a função COUNTA ou CONT.VALORES, e a função COUNTBLANK ou CONTAR.VAZIO, e alerto para as peculiaridades na contagem de alguns tipos de células.

divider

Contagem de CÉLULAS COM NÚMEROS
COUNT() ou CONT.NÚM()

A função COUNT e CONT.NÚM contará células que contêm números.

Sua sintaxe é :

=COUNT( Valor1, Valor2, … Valor30 ) em Inglês.
=CONT.NÚM( Valor1; Valor2; … Valor30 ) em Português.

Os argumentos…

Por exemplo Valor1 pode ser referências de célula (Ex: A1), ou valores digitados na fórmula COUNT ou CONT.NÚM.

O exemplo a seguir que utiliza a função COUNT ou CONT.NÚM em seu argumento faz uma referência para as células A1: A5.

 

=Cont.Núm() -Contagem de Números

 

  1. Digite os dados de exemplo em sua planilha.
  2. Na célula A7, introduza uma fórmula de COUNT ou CONT.NÚM , para contar os números na coluna A.
  3. Função CONTAGEM DE NÚMEROS Excel. = COUNT( A1: A5 ) ou = CONT.NÚM( A1: A5 ).
  4. Pressione a tecla Enter , para completar a fórmula .
  5. O resultado será de 3 , o número de células que contêm números .
  6. A célula A1 não é contada pois contém texto.
  7. A célula A4 não é contada pois está vazia.

divider

Contagem de CÉLULAS COM DADOS
COUNTA() ou CONT.VALORES()

A função COUNTA ou CONT.VALORES contará células que não estão vazias .

Sua sintaxe é :

=COUNTA( Valor1, Valor2 , … Valor30 ) em Inglês.
=CONT.VALORES( Valor1, Valor2 , … Valor30 ) em Português.
Os argumentos…

Por exemplo Valor1 pode ser referências de célula, ou valores digitados na fórmula.
O exemplo a seguir usa um argumento – uma referência para as células A1: A5.

2contar-itens-no-excel-contagem-de-dados-douglas-godoy

  1. Digite os dados de exemplo em sua planilha
  2. Na célula A7, introduzir uma fórmula COUNTA ou CONT.VALORES, para contar os números na coluna A:
  3. Função CONTAGEM DE DADOS = COUNTA( A1: A5 ) ou = CONT.VALORES( A1: A5 ).
  4. Pressione a tecla Enter, para completar a fórmula .
  5. O resultado será quatro , o número de células que contêm dados .

COUNTA ou CONT.VALORES contará células que estão preenchidas com fórmulas, números o qualquer informação.

Nota:
Este tipo de contagem inclui aquelas células que recebe o resultado vazio, com aspas dupla ” “.
Por exemplo, = IF(B2 = ” ” , ” “, B2), o resultado é considerado como preenchido .
As células que tinham fórmulas que tiveram como resultado ” “, serão contadas também.

divider

Contagem de CÉLULAS EM BRANCO
COUNTBLANK() ou CONTAR.VAZIO()

A função COUNTBLANK ou CONTAR.VAZIO contará células que estão vazias.

Sua sintaxe é :

=COUNTBLANK( Intervalo ) em Inglês..
=CONTAR.VAZIO( Intervalo ) em Português.

O exemplo a seguir usa uma referência para as células A1: A5.

3-contar-itens-no-excel-contagem-de-celulas-vazias-douglas-godoy

 

  1. Digite os dados de exemplo em sua planilha.
  2. Na célula A7, introduzir uma fórmula COUNTBLANK , para contar os números na coluna A :
  3. = COUNTBLANK (A1: A5)
  4. Pressione a tecla Enter , para completar a fórmula .
  5. O resultado será um , o número de células vazias .

Nota:
Este tipo de contagem inclui aquelas células que recebe o resultado vazio, com aspas dupla ” “.
Por exemplo, = IF(B2 = ” ” , ” “, B2), o resultado é considerado como preenchido .
As células que tinham fórmulas que tiveram como resultado ” “, serão contadas também.

divider

Contagem de CÉLULAS COM CRITÉRIO EXATO
COUNTIF() ou CONT.SE()

No exemplo abaixo você aprenderá a usar a função COUNTIF ou CONT.SE para contar células que contêm uma seqüência específica de texto, ou uma determinada palavra ou item, como por exemplo “AMAR” .

As instruções escritas estão abaixo são para o critério de correspondência exata e critério de correspondência em uma string, buscando apenas a palavra exata.

Sua sintaxe é :

=COUNTIF( Intervalo, Critério ) em Inglês..
=CONT.SE( Intervalo; Critério ) em Português.

O exemplo a seguir usa uma referência para as células A1: A10.

4-contar-itens-no-excel-contagem-de-celulas-com-condicao-cont-se-douglas-godoy

No Excel, será feita a contagem de células que atendam ao critério específico .
Neste exemplo , apenas as células que contém AMAR será contada.

  1. Selecione a célula na qual você quer ter o resultado da contagem. (A12 célula neste exemplo)
  2. Escreva um sinal de igual ” = ” para iniciar a fórmula.
  3. =COUNTIF( ) ou =CONT.SE( ).
    A fórmula completa é : = COUNTIF ( A1 : A10 , “AMAR” )
  4. Selecione as células que contêm os valores para verificar o critério.
    Neste exemplo , as células A1 : A10 será verificado.
  5. Digite uma vírgula, para separar os argumentos.
  6. Digite o critério.
  7. Neste exemplo, você está verificando para um texto, então digite a palavra entre aspas : “AMAR”

Nota:
Letras maiúsculas e minúsculas são tratadas com igualdade.

divider

Contagem com Critério  de CORRESPONDÊNCIA
COUNTIF() ou CONT.SE()

No exemplo abaixo você aprenderá a contar células que contêm um determinado pedaço do Critério.

As instruções escritas estão abaixo são para o critério de correspondência parcial, este critério é mais conhecido como critério de correspondência em uma string, contando apenas os itens que contém o trecho determinado.

Sua sintaxe é :

=COUNTIF( Intervalo, “Critério* ) em Inglês..
=CONT.SE( Intervalo; “Critério* ) em Português.
5-contar-itens-no-excel-contagem-de-celulas-com-condicao-cont-se-criteiro-com-parte-da-palavra-douglas-godoy

  1. Selecione a célula na qual você quer ter o resultado da contagem. (A12 célula neste exemplo)
  2. Escreva um sinal de igual ” = ” para iniciar a fórmula.
  3. =COUNTIF( ) ou =CONT.SE( ).
    A fórmula completa é : = COUNTIF ( A1 : A10 , “*AMAR*” )
  4. Selecione as células que contêm os valores para verificar o critério.
  5. Neste exemplo , as células A1 : A10 será verificado.
  6. Digite o critério. Neste exemplo, você está verificando o texto , então digite a palavra entre aspas, com um ou mais asteriscos (*) caracteres curinga : ” * AMAR * “

 

Nota:
Letras maiúsculas e minúsculas são tratadas com igualdade.
A fórmula completa é  : = COUNTIF ( A1 : A10 , ” * AMAR * ” )

O resultado será 6 , o número de células que contêm a sequencia, “AMAR”, seja no inicio, no meio ou no final da frase.

Dica:

Em vez de digitar o critério em uma fórmula, você pode se referir a uma célula .
Por exemplo , a fórmula no passo 7 acima poderia ser alterada para :
= COUNTIF ( A1 : A10 , ” * ” &  A7 & ” * ” ), teria o mesmo efeito de escrever ” * AMAR *”.

divider

Contagem de NÃO DUPLICADOS (únicos)
SUMPRODUCT() ou SOMARPRODUTO ()

Tenha cuidado ao usar COUNTIF ou CONT.SE , porque pode coincidir a contagem de números com texto, o que pode resultar em falsas acusações.

Por exemplo, se você tem uma entrada de texto – ” 00123 ” – seria contada como uma duplicata para o número – 123 .

= COUNTIF ( $B$2: $B$10, B2) ) > 1
= CONT.SE ( $B$2: $B$10; B2) ) > 1

Se os seus dados podem conter entradas como essa, use SUMPRODUCT ou SOMARPRODUTO , em vez de COUNTIF ou CONT.SE .

= SUMPRODUCT (- ( $B$2: $B$10 = B2) ) > 1
= SOMARPRODUTO  (- ( $B$2: $B$10 = B2) ) > 1

6-contar-itens-no-excel-contagem-de-celulas-sem-duplicidades-douglas-godoy

divider

Contagem de CÉLULAS MAIOR OU IGUAL À
COUNT() ou CONT.NÚM()

Para aplicar a condição você deve usar um operador com um critério.

Neste exemplo, apenas as linhas em que a quantidade é maior do que ou igual a 100 será contado.

  1. Selecione a célula na qual você quer ter o resultado da contagem. (B12 célula neste exemplo)
  2. Escreva um sinal de igual ” = ” para iniciar a fórmula.
  3. =COUNTIF( ) ou =CONT.SE( ).
    A fórmula completa é : = COUNTIF ( B1 : B10 , ” > = 100 ” )
  4. Digite o critério.
    Neste exemplo, você está verificando para as linhas onde a quantidade é maior ou igual a 100.
  5. A > = operador é usado antes do número , e todo o critério está entre aspas duplas : “> = 10 “

Nota: Mesmo sendo um critério numérico, ele deve contidas em aspas duplas.
A fórmula é completa := COUNTIF ( B1 : B10 , ” > = 10 ” )

7-contar-itens-no-excel-criterio-acima-ou-abaixo-valor-douglas-godoy

divider

[ideia]Temos neste artigo um Overview com 7 maneiras de Contar de Itens no Excel, estas são apenas propostas pois sei que a utilização do Excel não possui limites e podemos encontrar diversas formas de fazermos uma única coisa. [/ideia]

Caso conheça mais alguma forma de Conta  itens no Excel  peço que compartilhe conosco.

Agradeço pela leitura e fico no aguardo de seus comentários e sugestões.

Um abraço. Douglas Godoy

Comentários