Contar células entre dois números

Olá amigos, no artigo anterior eu lhes ensinei como contar células entre datas, (Link aqui), neste artigo atual você aprenderá como Contar células entre dois números, muitas vezes precisamos saber quantas células estão entre dois valores, para isso utilizaremos duas funções, sendo:

  • CONT.SES( )
  • CONT.SE( )

Abaixo temos um exemplo com a fórmula e com os dados do nosso exemplo.

Contar células entre dois números

Contar células entre dois números

=CONT.SES(Intervalo;">=X";Intervalo;"<=Y")

Explicação

Para contar o número de células que contêm valores entre dois números em um intervalo de células, você pode usar a função COUNTIFS. Na forma genérica da fórmula (acima) o intervalo representa um intervalo de células que contêm números, X representa o limite inferior e Y representa o limite superior dos números que você deseja contar.

No exemplo, a célula ativa contém esta fórmula:

=CONT.SES(C4:C10;">=80";C4:C10;"<=90")

 Como funciona esta fórmula

A função CONT.SES é criada para contagem de células que atendam a critérios múltiplos.
Neste caso, uma vez que fornecemos o mesmo intervalo para dois critérios, cada célula no intervalo deve satisfazer ambos os critérios para ser contado.

Usando o COUNTIF

Se você tiver uma versão mais antiga do Excel que não tem a função CONT.SES, você pode usar a função CONT.SE como este:

=CONT.SE(Intervalo;">=X")- CONT.SE(Intervalo;">Y")
=CONT.SE(A1;">=20")- CONT.SE(A1;">30")

O primeiro CONT.SE conta o número de células em um intervalo que são maiores ou iguais a X (que por definição também inclui valores maiores que Y, já que Y é maior que X). O segundo CONT.SE conta o número de células com valores maiores que Y. Este segundo número é então subtraído do primeiro número, o que produz o resultado final – o número de células que contêm valores entre X e Y.

Tornar a variável de critérios

Se você desejar usar um valor em outra célula como parte dos critérios, use o caractere & comercial (&) para concatenar como este:

=CONT.SE(Intervalo;">"&a1)

Se o valor na célula a1 for “5”, o critério será “> 5″(Maior que Cinco) após a concatenação.

Espero que tenha gostado do artigo, deixe seu comentário e opnião.

Um abraço.
Douglas Godoy

CONFIRA TAMBÉM:

7 Maneiras de contar Itens no Excel
http://douglasgodoy.com.br/overview-7-maneiras-de-contar-de-itens-no-excel/

Contar células entre datas
http://douglasgodoy.com.br/contagem-de-celulas-entre-datas/

Comentários

  • Diego P
    Responder

    Boa tarde!
    Obrigado pelo seu ensinamento, me foi muito útil.

    • Douglas Godoy

      Olá Diego P,

      Muito Obrigado pelo seu comentário!

      Um abraço!