Contagem de células entre datas

Olá amigos, neste artigo você aprenderá como realizar a Contagem de células entre datas, muitas vezes temos muitas datas e precisamos saber quantas datas tem em determinado ano da nossa base de dados, para isso utilizaremos duas funções, sendo:

  • DATA( )
  • CONT.SES( )

Abaixo temos um exemplo com a fórmula e com os dados do nosso exemplo.

 Contagem de células entre datas

Contagem de células entre datas – Explicação

Para contar o número de células que contêm datas entre duas datas, você pode usar a função COUNTIFS.

No exemplo mostrado abaixo, F3 contém esta fórmula:

=CONT.SES($C$3:$C$12;">="&DATA(E3;1;1);$C$3:$C$12;"<="&DATA(E3;12;31))

Esta fórmula conta os premiados do ano 2014 a 2017 que aparecem no intervalo C3: C10.

Como funciona esta fórmula?

A função CONT.SES ou COUNTIFS (em inglês)  é criada para contagem de células que atendam a critérios múltiplos.
Neste caso, precisamos fornecer dois critérios: um critério para a data inicial e outro para a data final, tudo que estiver entre a data inicial e for do ano será contado.

Nós fornecemos as datas no intervalo de células (C3: C10) para ambos os critérios.

Para construir cada data, usamos a função DATA:

DATA (E3,1,1) // primeiro dia do ano
DATA (E3,12,31) // último dia do ano

A função DATA facilita a criação de datas com base em argumentos de ano, mês e dia que são codificados ou fornecidos como referências de célula. No exemplo, mês e dia são codificados, e obtemos ano da coluna E.

Observe que”>=” e “<=” devem ser inseridos como texto e rodeados por aspas.
Isto significa que devemos usar concatenação (&) para juntar cada operador a cada data.

Quando usamos o operador “>=” ele conta se da data for maior ou igual, ou menor ou igual a condição determinada.

Espero que tenha gostado do artigo e que tenha lhe ajudado.

Um abraço.
Douglas Godoy

CONFIRA TAMBÉM:

7 Maneiras de contar Itens no Excel
http://douglasgodoy.com.br/overview-7-maneiras-de-contar-de-itens-no-excel/

 

 

Comentários