Formulário de Pesquisa com VBA

O artigo de hoje faz parte da série de artigos Aprendendo VBA, e te ensinará a criar um Formulário de Pesquisa com VBA. Você aprenderá como Criar um Formulário de Pesquisa com o VBA a partir do Zero, mesmo se você não tiver muito conhecimento em VBA se você seguir o passo a passo e assistir […]

Como Listar todas tabelas dinâmicas do seu arquivo Excel com VBA

Olá Amigo, neste artigo você aprenderá a Listar todas tabelas dinâmicas do seu arquivo Excel com VBA. Muitas vezes estamos trabalhando com arquivos grandes e na maioria das vezes estes arquivos possuem muitas tabelas dinâmicas, conexões e vínculos, a pior coisa do mundo é quando atualizamos nossa base de dados vinculada ao SQL e e somos […]

Aprenda a Cálcular a Venda Média por Mês

Olá amigos, no artigo anterior eu lhes ensinei como “Contar células entre dois números”, (Link aqui)… Neste artigo atual você aprenderá como calcular a Venda Média por Mês, muitas vezes precisamos saber qual a média de vendas por mês, para isso utilizaremos duas funções, sendo: MÉDIASES( ) FIMMÊS( ) Abaixo temos um exemplo com a […]

Contar células entre dois números

Olá amigos, no artigo anterior eu lhes ensinei como contar células entre datas, (Link aqui), neste artigo atual você aprenderá como Contar células entre dois números, muitas vezes precisamos saber quantas células estão entre dois valores, para isso utilizaremos duas funções, sendo: CONT.SES( ) CONT.SE( ) Abaixo temos um exemplo com a fórmula e com os […]

Contagem de células entre datas

Olá amigos, neste artigo você aprenderá como realizar a Contagem de células entre datas, muitas vezes temos muitas datas e precisamos saber quantas datas tem em determinado ano da nossa base de dados, para isso utilizaremos duas funções, sendo: DATA( ) CONT.SES( ) Abaixo temos um exemplo com a fórmula e com os dados do […]

Formulário de Cadastro com VBA

O que acha de aprender a criar um formulário de cadastro com VBA?

Vídeo aula completa que explica como criar um formulário de cadastro.

É o que explico neste artigo completo, com direito a um conteúdo completo, vídeo aula explicando os detalhes e ainda com a opção de fazer o download da planilha.

Confira!

Como conseguir o caminho de uma pasta utilizando VBA

Olá amigos, Muitas vezes estamos desenvolvendo uma rotina, sistema ou aplicação com o VBA, que exige que tenhamos de selecionar uma determinada pasta, seja para abrir um determinado aquivo ou para salvar os arquivos da rotina em determinada pasta. Para resolver este problema temos a rotina abaixo que faz a exibição da caixa de seleção e […]

Aprendendo como enviar Email com VBA usando o Excel

Olá Amigos, Venho mais esta postagem que tenho certeza que lhe ajudará muito em suas rotinas diárias. Aprendendo como enviar Email com VBA usando o Excel Muitas vezes estamos preparando um relatório e necessitamos enviar este por email, é muito trabalhoso ter te ficar procurando nos itens enviados o último relatório para ter de replicar […]

Aprendendo VBA – Como deixar um formulário ficar com tela cheia!?

Olá Amigos, Algumas vezes ao desenvolvermos um formulário em VBA necessitamos que o mesmo ocupe toda a tela do monitor. Isso pode ser um problema tendo em vista que  existem atualmente milhares de opções de configurações de tela, o que torna praticamente impossível fazer isso apenas pela configuração normal de altura e largura. Para resolver este […]

VBA – Listar os nomes de suas planilhas

Olá Amigos, Estava elaborando uma ferramenta para uma cliente quando me deparei com a necessidade de Listar os nomes das planilhas Excel, quando me dei conta que um dos relatórios que tinha de ser gerado possuía mais de 200 Sheets, ai pensei, e agora? Para situações como estas devemos recorrer ao bom e velho VBA… […]

ARRED ou ROUND – Função Excel

Aprendendo Excel… Mais uma dica para você aprender Excel de forma simples e rápida. =ARRED() ou =ROUND() A função ARRED arredonda um número para um número especificado de dígitos. Por exemplo, se a célula A1 contiver 23,7825 e pretender arredondar esse valor para duas casas decimais, poderá utilizar a seguinte fórmula: =ARRED(A1;2) O resultado desta […]

SOMA ou SUM – Função Excel

Aprendendo Excel… Mais uma dica para você aprender Excel de forma simples e rápida. =SOMA() ou =SUM() Retorna o valor da soma de determinadas células. Também retorna o valor de soma dos argumentos. Você pode incluir até 255 valores numéricos ou referências de célula ou intervalo, em qualquer combinação, como argumentos na função soma . […]

Mod – Fórmula Excel

Aprendendo Excel… Mais uma dica para você aprender Excel de forma simples e rápida. =MOD() Retorna o resto da divisão. O resultado tem o mesmo sinal do divisor.   Agradeço pela leitura e fico no aguardo de seu comentário e sugestões. Um abraço. DG